ハマログ

株式会社イーツー・インフォの社員ブログ

Eclipseプロジェクト・ファセットの動的Webモジュールのバージョンをダウングレードする

ローカル環境構築に伴い、プロジェクト・ファセットの動的Webモジュールのバージョンを3.0から2.5へダウングレードしたかったのですが、
Eclipseから設定を変更しようとするとエラーメッセージが表示されダウングレードできません。OKボタンが押下できないのです(ノ◇≦。)
金子リーダーと調査して対策したのでメモ書き。

私のEclipse環境は
Eclipse Java EE IDE for Web Developers.
Version: Kepler Service Release 2
Build id: 20140224-0627
です。

「プロジェクト・ファセットのバージョンを動的Webモジュールから変更できません」というエラーメッセージが表示されてしまいます。
image

この場合、直接設定ファイルを編集するとダウングレード可能なんです。
C:{プロジェクトディレクトリ}\.settings\org.eclipse.wst.common.project.facet.core.xmlを編集します。
image2

Eclipseを再起動するとバージョンが変更されていることが確認できます。

Eclipse上から設定変更できないということは、ダウングレードによって何らかの不具合が生じる可能性があるってことなのでしょうか?
今のところ、WebアプリケーションTomcat 6.0できちんと動いています(>y<;)

Dynamic Web ModuleEclipseJavaJavaEEProject Facetsプロジェクト・ファセット動的Webモジュール

S.I   S.I   2014年10月14日


関連記事

Chromecastとは

ChromecastはGoogleが開発したHDMIドングル型のメディアストリー…

Eclipse起動しなくなったので解決しましたの巻

突然Eclipseが起動しなくなりました。 画面に表示されるエラー内容は以下のと…

MacOS XのGatekeeper

こんにちは、かねこです。 今流行のSASS/LESSをShin先輩に調べてもらっ…


← 前の投稿

次の投稿 →