ハマログ

株式会社イーツー・インフォの社員ブログ

laravel4 PHP5でいきなりででるsyntax error

laravel4のbladeにHTMLに埋め込みした際に「syntax error」がでました。
image
改修していない箇所なのに…(ノ◇≦。)
対策をしたのでその記録!!

先頭の『<?』がPHPコードのオープンタグと勘違いされてPHPのパースエラーが出ている模様。
回避策としてPHPコードのオープンタグに<?は使わず<?php を使うようにして、
PHPの設定でショート・オープンタグ(<?)を無効にする設定を行います。

php.iniに以下設定を行います。

short_open_tag = On

これで無事解決されました。
念のため、ブラウザーキャッシュとapp/storage/views直下にキャッシュの削除も行いましょう!!

よかったー(b´ω`d)日々、お勉強です。

LaravelPHPsyntax errorxampp

S.I   S.I   2014年9月16日


関連記事

AWSに設置したphpMyAdminにBasic認証を設定/特定のIPアドレスによる制限

AWSで、ELB→EC2の環境にphpMyAdminを設置しました。 yumコマ…

LaravelのdeployはRocketeerで!

Rocketeerは、PHPのタスク管理&デプロイ用のプロダクトです。 Lara…

Laravel5.1のリリース

Laravel5.1がリリースされました。PSR-2の採用、イベントブロードキャ…


← 前の投稿

次の投稿 →